1 Составить программу ** языке Паскаль. Написать программу, заносящую в файл массив из 7...

0 голосов
22 просмотров

1 Составить программу на языке Паскаль. Написать программу, заносящую в файл массив из 7 вещественных чисел, введенных с клавиатуры, а потом считывающую этот массив и выводящую на экран количество отрицательных элементов. Если таких нет, то выдать об этом сообщение.

2. Составить программу на языке Паскаль. Описать функцию нахождения максимума для двух величин. Ввести с клавиатуры a,b,c,d. Для каждой пары величин найти максимальную, а потом напечатать большее из максимальных величин.


Информатика (12 баллов) | 22 просмотров
Дан 1 ответ
0 голосов

1)
var f:text; a:array[1..7] of real; i,k,c,x:integer; s:string;
begin
 for i:=1 to 7 do
   begin
    readln(x);
    a[i]:=x;
   end;
 assign(f,'file.txt');
 rewrite(f);
 for i:=1 to 7 do
   begin
    str(a[i],s);
    writeln(f,s);
   end;
 close(f);
 reset(f);
 k:=0;
 while not eof(f) do
   begin
    readln(f,s);
    val(s,x,c);
    if x<0 then k:=k+1;<br>   end;
 close(f);
 if k<>0 then writeln('В массиве ',k,' отрицательных элемента(ов)');
  else writeln('В массиве нет отрицательных элементов');
 erase(f);
end.

2)
Var a,b,c,d:integer;

Function max(a,b:integer):integer;
begin
 if a>b then max:=a
  else max:=b;
end;

Begin
 readln(a,b,c,d);
 a:=(max(a,b)); 
 b:=(max(c,d));
 writeln('max=',max(a,b));
End.

(472 баллов)