Напишите программу ** PascalAbc, которая находит n-ое число из ряда Фибоначи

0 голосов
63 просмотров

Напишите программу на PascalAbc, которая находит n-ое число из ряда Фибоначи


Информатика (24 баллов) | 63 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.Net 3.2
//числа Фибоначчи
begin
var x1:=1; var x2:=0;
for var i:=1 to readinteger('n=') do
begin
x2+=x1;
x1:=x2-x1;
end;
write ('Fib(n)=', x2)
end.

(3.8k баллов)