Помогите написать программу в Pascal, которая вычисляет среднюю оценку за неделю (с...

0 голосов
103 просмотров

Помогите написать программу в Pascal, которая вычисляет среднюю оценку за неделю (с помощью массивов)


Информатика (67 баллов) | 103 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Program n1;
const n=12;
var a: array[1..n] of integer;
i,sum: integer;
begin
randomize;
sum:=0;
write('оценки за неделю: ');
for i:=1 to n do
begin
a[i]:=random(4)+2;
write(a[i],' ');
end;
writeln;
for i:=1 to n do sum:=sum+a[i];
writeln('среднее арифмитическое: ',sum/n);
end.

(149k баллов)
0

Нызко...

0

в задании не указывалось использовать динамические массивы, поэтому сделал как проще

0

Я имел в виду не код

0

а что тогда?

0

Если действительно знаете - хорошо, не знаете - еще лучше)

0 голосов

//PascalABC.Net
begin
var a: array of integer;
setLength (a, readinteger('Введите кол-во учеников: '));
for var i:=0 to length(a)-1 do a[i]:=readinteger ('Введите оценку ученика: ');
write ('Средняя оценка: ', a.Average);
end.

(3.8k баллов)