Составьте программу к следующей задаче:Ученик начал решать задачи данного урока...

0 голосов
109 просмотров

Составьте программу к следующей задаче:

Ученик начал решать задачи данного урока программирования, когда электронные часы показывали h1 часов и min1 минут, а закончил, когда было h2часов и min2 минут. Составьте программу, позволяющую определить, сколько времени (в часах и минутах) ученик решал эти задачи.


Информатика (412 баллов) | 109 просмотров
0
0

что это

0

опять ты

0

По указанному адресу - решение Вашей задачи.

0

ты не понятно ответил все равно

0

мы на инфе не так решаем

Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;

int main() {
int h1,min1,h2,min2,h,min,m;
cin >> h1 >> min1;
cin >> h2 >> min2;
m = (h2*60+min2)-(h1*60+min1);
h = m / 60;
min = m % 60;
cout << "h = " << h << " min = " << min;<br> return 0;
}

Пример:
1 55
3 15
h = 1 min = 20

(194k баллов)
0

да что это? я нифига не понимаю, мы не так решаем

0

Это решение Вашей задачи на С++. Я не могу знать что Вы знаете и как решаете задачи в школе.

0

Но это же сайт для школьников, зачем вы помогаете решать ДЕТЯМ задачи, но не так как в школе,