Составить программу в паскале , которая в массиве из десяти целых чисел считает среднее...

0 голосов
56 просмотров

Составить программу в паскале , которая в массиве из десяти целых чисел считает среднее арифметическое отрицательных.


Информатика (19 баллов) | 56 просмотров
0

С клавиатуры

Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger('Вводите:',10);
  Writeln('Ср.арифм. отрицательных чисел ',a.Where(x->x<0).Average)<br>end.

Пример
Вводите: 5 -3 2 8 11 21 -42 16 0 5
Ср.арифм. отрицательных чисел -22.5
(150k баллов)
0 голосов

Const n=10; 
var a:array[1..n] of integer;
i,s,k:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51)-25;
 write(a[i]:4);
 end;
writeln;
s:=0; k:=0;
for i:=1 to n do
 if a[i]<0 then begin s:=s+a[i]; k:=k+1; end;<br>writeln('s = ',s,' k = ',k);
if k>0
 then writeln('Среднее арифметическое отрицательных = ',s/k)
 else writeln('Отрицательных нет');
end.

Пример:
Массив A:
 -11  11  13   9 -11  -2  18 -18   3 -14
s = -56 k = 5
Среднее арифметическое отрицательных = -11.2

(194k баллов)