Найти сумму нечетных чисел от 1 до n. составьте программу в Паскаль

0 голосов
120 просмотров

Найти сумму нечетных чисел от 1 до n.
составьте программу в Паскаль


Информатика (35 баллов) | 120 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var n,i: integer;
sum: real;
begin
sum:=0;
readln(n);
for i:=1 to n do if i mod 2<>0 then
sum:=sum+i;
writeln(sum);
end.

(150k баллов)
0

что значит sum?

0

переменная типа real

0

а как можно записать без неё?

0

нельзя,в эту переменную записывается сумма

0

А почему sum имеет тип real (просто интересно)?

0

чтобы при очень большом n разряды не потерялись

0

Можно тогда было взять 64-битные числа (int64, uint64)

0

для школы сложновато)

0

Сегодня вычисляли факториал 150000 (через biginteger)

0

Длина числа>100000 знаков))