Напишите программу, которая требует у вас пароль ,например, 246. Если пароль правильный,...

0 голосов
117 просмотров

Напишите программу, которая требует у вас пароль ,например, 246. Если пароль правильный, то выводит сообщение :"молодец!", иначе -"неверный пароль". Если после пятой попытки пароль все равно неверен, выводит сообщение : "карта заблокирована".


Информатика (228 баллов) | 117 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var pas: string;
k: integer;
begin
readln(pas);
k:=0;
while true do if pas='246' then
begin
write('молодец');
break;
end else
begin
k:=k+1;
writeln('неверный пароль');
readln(pas);
if k=5 then begin write('карта заблокирована');
break;
end;
end;
end.

(149k баллов)