Помогите решить задачу с информатики пж!!!))СРОЧНО!!!!35б Нужно написать программу. Дано...

0 голосов
61 просмотров

Помогите решить задачу с информатики пж!!!))СРОЧНО!!!!35б
Нужно написать программу.
Дано 2 числа a і b. Поміняти їх значення місцями двома способами: 1) з використанням третьої змінної; 2) за допомогою арифметичних операцій.


Информатика (268 баллов) | 61 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c:integer;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
//1
c:=a; a:=b; b:=c;
writeln('a = ',a,' b = ',b);
//2
a:=a+b; b:=a-b; a:=a-b;
writeln('a = ',a,' b = ',b);
end.

Пример:
a = 5
b = 8
a = 8 b = 5
a = 5 b = 8

(194k баллов)
0

Спасибо!!)))

0

Пожалуйста.