Найти кол-во гласных букв в строке?(Паскаль)

0 голосов
133 просмотров

Найти кол-во гласных букв в строке?(Паскаль)


Информатика (30 баллов) | 133 просмотров
0

Пожалуйста помогите!!!!СРОЧНО НАДО!!!

Дан 1 ответ
0 голосов
Правильный ответ

Const glr='АЕЁИОУЫЭЮЯаеёиоуыэюя'; gle='AEIOUYaeiouy';
var s:string; k,i:integer;
begin
writeln('Введите строку:');
readln(s);
k:=0;
for i:=1 to length(s) do
 if pos(s[i],glr)+pos(s[i],gle)>0 then k:=k+1;
writeln('k = ',k);
end.

Пример:
Введите строку:
Primer пример.
k = 4

(194k баллов)
0

А что такое const glr и gle?

0

Строковые константы (const), содержащие русские и английские гласные буквы соответственно.

0

А их обязательно писать?Просто раньше в школе никогда такого не писали.

0

В этом варианте программы - обязательно. Можете написать программу по-другому и не использовать такие константы.