Очень нужно) Информатика, программирование ** языке паскаль. 1.Введенную строку вывести в...

0 голосов
96 просмотров

Очень нужно) Информатика, программирование на языке паскаль.
1.Введенную строку вывести в обратном порядке (с последней буквы начинается и первой заканчивается)
2.Напишите программу, которая определить какой символ A или B встречается чаще.


Информатика (1.3k баллов) | 96 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  Writeln(s.Inverse)
end.

Пример
Я пишу программу на языке Паскаль
ьлаксаП екызя ан уммаргорп ушип Я

// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите строку:');
  Write('Введите два символа СЛИТНО для сравнения их частоты: ');
  var ab:string;
  Readln(ab);
  var a:=ab[1];
  var b:=ab[2];
  var ka:=0;
  var kb:=0;
  for var i:=1 to s.Length do
    if s[i]=a then ka+=1
    else if s[i]=b then kb+=1;
  if ka>kb then Writeln('Символ ',a,' встречается чаще, чем ',b)
  else
    if ka    else
      if ka<>0 then Writeln('Символы ',a,' и ',b,' встречается одинаково')
      else Writeln('Символы ',a,' и ',b,' отсутствуют')
end.

Пример
Введите строку: а роза упала на лапу азора
Введите два символа СЛИТНО для сравнения их частоты: ао
Символ а встречается чаще, чем о
(150k баллов)
0

Во второй задаче то, что в скобках во второй строке это писать в программе?

0

первая задача такая короткая, это првильно для 9 класса?

0

Write('Введите два символа СЛИТНО для сравнения их частоты: ');

0

эту фразу прям писать в программе