Напишите программу среднее геометрическое всех чисел ** отрезке (a b)

0 голосов
30 просмотров

Напишите программу среднее геометрическое всех чисел на отрезке (a b)


Информатика (17 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

//PascalABC.Net 3.2
begin
var prod:=1;
var a:=readinteger('a ='); var b:=readinteger('b =');
for var i:=a to  b do prod*=i;
write ('Ср. геометрическое: ', prod/(b-a))
end.

(3.8k баллов)