Помогите решить задачу с информатики пж!!!))Нужно написать программу. Дано значення двох...

0 голосов
44 просмотров

Помогите решить задачу с информатики пж!!!))Нужно написать программу. Дано значення двох моментів часу, які належать одній і тій же добі. Години, хвилини і секунди для кожного з моментів часу. Відомо, що другий момент часу наступив не раніше першого. Визначити скільки секунд пройшло між двома моментами часу. Вхідні дані: програма на вхід отримує 6 цілих чисел. Перших 3 числа - це години,хвилини і секунди, які задають перший момент часу і інші 3 числа, які задають другий момент часу. Вихідні дані: виведіть число секунд між цими моментами часу.

(Начало решения:)
var h, m, s, h1, m1, s1, a, a1, b: integer;
begin
read (h, m, s, h1, m1, s1);
a:= h*3600+m*60+s


Информатика (268 баллов) | 44 просмотров
0

Извините, можно перевести?

0

Даны значения 2 моментов времени,принадлежащих одной и той же эпохе.Часы,минуты,секунды для каждого из моментов времени.Известно,что 2-ой момент времени наступилНЕранее первого.Определить сколько секунд прошло между двумя моментами времени.Входные данные:программа на вход получает 6 целых чисел.Первых 3 числа-это часы,минуты,секунды,которые задают 1-вый момент времени и другие 3числа,которые задают 2-ой момент времени.Выходные данные:выведите число секунд между этими моментами времени.

Дан 1 ответ
0 голосов
Правильный ответ

Var
A,B,C,D:integer;
Begin
Read(A,B,C);
D:=A*3600+B*60+C;
Read(A,B,C);
D:=A*3600+B*60+C-D;
WriteLn(D);
End.

(34.0k баллов)