Напишите программу, которая вводит номер месяца и выводит название времени года. оператор...

0 голосов
159 просмотров

Напишите программу, которая вводит номер месяца и выводит название времени года. оператор выбора использовать не разрешается. При вводе неверного номера месяца должно быть выведено сообщение об ошибке. (ПАСКАЛЬ)


Информатика (133 баллов) | 159 просмотров
0

Оператор выбора - это if или Case ? Или оба?

0

Case

Дан 1 ответ
0 голосов
Правильный ответ

Var A:integer;
Begin
Read(A);
A:= A mod 12;
if (A>=0)and(A<3) then Write('Зима');<br>if (A>2)and(A<6) then Write('Весна');<br>if (A>5)and(A<9) then Write('Лето');<br>if (A>8)and(A<=11) then Write('Осень');<br>End.

(34.0k баллов)