Задача ** c++ Необходимо написать программу, которая вычислит сумму 2/3+3/4+4/5+...+n−1n....

0 голосов
33 просмотров

Задача на c++
Необходимо написать программу, которая вычислит сумму

2/3+3/4+4/5+...+n−1n.
Формат входных данных

Вводится натуральное число N (3≤N≤105).
Формат выходных данных

Программа должна вывести результат вычисления одним вещественным числом с точностью до шести знаков после запятой.


Информатика (280 баллов) | 33 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;

int main()
{
    int n;
    double s=0;
    cout << "n = ", cin >> n, cout << "\n";<br>    for (int i=2; i    s += (double)i/(i+1);
    }
    cout.setf(ios::fixed);
    cout.precision(6);
    cout << "s = " << s << "\n";<br>    return 0;
}

Пример:
n = 10
s = 6.571032

(194k баллов)