Составьте программу в Паскале Найдите сумму чисел,кратных 2 из диапазона от 1 до 38....

0 голосов
77 просмотров

Составьте программу в Паскале
Найдите сумму чисел,кратных 2 из диапазона от 1 до 38.
Найдите произведение чисел ,кратных 4 из диапазона от 2 до 25.


Информатика (63 баллов) | 77 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var i,s,p: longint;
begin
s:=0;
p:=1;
for i:=1 to 38 do if i mod 2=0 then s:=s+i;
for i:=2 to 25 do if i mod 4=0 then p:=p*i;
writeln('сумма: ',s);
writeln('произведение: ',p);
end.

(150k баллов)