СРОЧНО!!!1)Составьте программу сумму и разность целых чисел A и B.2)Составьте программу...

0 голосов
29 просмотров

СРОЧНО!!!1)Составьте программу сумму и разность целых чисел A и B.2)Составьте программу нахождения первой цифры двухзначного числа а.3) Составьте программу вычисление суммы двузначного числа а.4) Составьте программу вычисления суммы цифр трехзначного числа а. Это разные задания !!!!


Информатика (37 баллов) | 29 просмотров
0

пожалуйста помогите

Дан 1 ответ
0 голосов
Правильный ответ

1)
var a,b:real;
begin
readln(a,b);
writeln('А-Б=',a-b);
writeln(А+Б=',a+b);
end.
2)
var a:string;
begin
readln(a);
write(copy(a,0,1);
end.
3)
var a,s1,s2:string;
begin
readln(a);
s1:=copy(a,0,1);
s2:=copy(a,1,1);
write('Сумма цифр числа',a,'=',s1+s2);
end.
4)
var a,s1,s2,s3:string;
begin
readln(a);
s1:=copy(a,0,1);
s2:=copy(a,1,1);
s3:=copy(a,2,1);
write('Сумма цифр числа',a,'=',s1+s2+s3);
end.

(674 баллов)
0

По идее должно быть так)

0

Да, СПАСИБО!!!☺

0

если это ты считаешь ответ правильным, поставь лучший ответ

0

твой ответ нельзя поставить лучшим,не знаю почему?

0

Короче, я не знаю!!!

0

Может быть появится тогда поставлю!!!