Напишите программу, которая определяет, верно ли, что введённое число содержит две...

0 голосов
165 просмотров

Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число. Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет. Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO


Информатика (25 баллов) | 165 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
const ny: array[boolean] of string[3] = ('No', 'Yes');
var n: longint; b: boolean;
begin
write('n = ');
readln(n);
n := abs(n);
b := false;
while n > 9 do
begin
b := n mod 10 = n mod 100 div 10;
if b then break;
n := n div 10
end;
writeln(ny[b]);
readln
end.

(149k баллов)