Написать программу которая с клавиатуры вводит 5 целых чисел и вычисляет среднее...

0 голосов
85 просмотров

Написать программу которая с клавиатуры вводит 5 целых чисел и вычисляет среднее арифметическое нечетных среди них.На ABC паскале пожалуйста


Информатика (19 баллов) | 85 просмотров
0

Pascal ABC

0

нужно

Дан 1 ответ
0 голосов
Правильный ответ

Var
A,S,i,n:integer;
Begin
n:=0;
S:=0;
For i:= 1 to 5 do
    Begin
    Read(A);
    if A mod 2 <> 0 then
    Begin
    S:=S+A;
    n:=n+1;
    WriteLn(A);
    End;
    End;
Write(S/n);
End.

(34.0k баллов)