Программирование в С++. В массиве В(12) все нецелые элементы из отрезка [a,b] занесите в...

0 голосов
60 просмотров

Программирование в С++.

В массиве В(12) все нецелые элементы из отрезка [a,b] занесите в массив С и найдите минимальный элемент массива С.


Информатика (38 баллов) | 60 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Как я понял то а и b - это индексы начала и конца перебора данного массива, если это так то решение таково :
#include
using namespace std;
 int main()
{
int B[12];
for(int i=0;i<12;i++)<br>cin>>B[i]; //занесение в первоначальный массив В
int a,b;
cin>>a>>b; //считывание необходимого промежутка
int C[b-a]; //обьявление конечного массива
for(int i=b-a,k=0;i{
С[k]=B[i]; // перенос нужных значений
}
int min=C[0]; //переменная в которой будет в итоге храниться минимальное знач.
for(int i=0;i<(b-a);i++)<br>{
if(C[i]min=C[i];
}
cout<<min; //вывод минимального элемента<br>return 0;
}

(76 баллов)