Написать программу ** паскале

0 голосов
59 просмотров

Написать программу на паскале


image

Информатика (165 баллов) | 59 просмотров
0

В первом случае + или - ?

0

Переменные r и z или только r?

0

только r

0

так как

0

В первом случае + или -

0

А, ну да..

Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017

begin
  var x,y:real; Read(x,y);
  var r:=(x>=y?x*x-y*y:x*x+y*y); Writeln(r)
end.
(150k баллов)
0 голосов

Program prog;
Uses crt;

var x,y,r: real;

begin
clrscr;

write('x = ');
readln(x);

write('y = ');
readln(y);

if (x>=y) then
r:=sqr(x)-sqr(y)
else
r:=sqr(x)+sqr(y);
writeln('r = ',r:0:3);
readln;
end.

(9.6k баллов)