** c++ ПОЖАЛУЙСТА Напишите программу, которая вводит номер месяца и выводит название...

0 голосов
163 просмотров

НА c++ ПОЖАЛУЙСТА
Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке. При вводе неверного номера месяца должно быть выведено слово 'NO'.

Входные данные
Входная строка содержит единственное число – номер месяца (возможно, неверный).

Выходные данные
Нужно вывести название времени года (на английском языке), соответствующее введённому номеру месяца ('winter' – зима, 'spring' – весна, 'summer' – лето, 'autumn' – осень). Если введён неверный номер месяца, программы должна вывести слово 'NO'.

Примеры
входные данные
4
выходные данные
spring


Информатика (503 баллов) | 163 просмотров
0

нет

0

Возможно

0

НУ так вы знаете решение?

0

Ну блин

0

Жалко

Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;
int main()
{
int num;
cin>>num;
if(num==1 || num==2 || num==12)
{cout<<"winter";} <br>else if (num==3 || num==5 || num==4)
{cout<<"spring";}<br>else if (num==6 || num==7 || num==8)
{cout <<"summer";}<br>else if(num==9 || num==10 || num==11)
{cout<<"autumn";} else cout<<"no";<br>return 0;
}

(150k баллов)
0

#include
int main()
{
int a;
scanf("d",&a);
if(a==1 || a==2 || a==12)
printf("zima/n");

if (a==3 || a==5 || a==4)
printf("spring/n");
if (a==6 || a==7 || a==8)
printf("summer/n");
if(a==9 || a==10 || a==11)
printf("autumn") ;else printf("no");
}

0

Я вот так сделал,где ошибка? ВСегда No выводит