Напишите программу, которая выводит все простые числа в диапазоне от K до N ( 2 ≤ K ≤ N ≤...

0 голосов
86 просмотров

Напишите программу, которая выводит все простые числа в диапазоне от K до N ( 2 ≤ K ≤ N ≤ 100000 ). Pascal


Информатика (36 баллов) | 86 просмотров
Дан 1 ответ
0 голосов

Var
 k,n,x,d: integer;

begin
 read(k,n);
 for x := k to n do
  if x mod 10 = 3 then
    begin
    d := 2;
    while x mod d <> 0 do d := d + 1;
    if x = d then write(x,' ');
    end;
end.

(106 баллов)
0

Спасибо, но мне нужен именно массив для этого от 2 до 100000