Вопрос №591394 (тип: C) Даны два целых числа a и b. Напишите программу, которая находит...

0 голосов
50 просмотров

Вопрос №591394 (тип: C)
Даны два целых числа a и b.
Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b

Входные данные:
В первой строке вводятся два целых числа a и b (a<=b, a,b не больше 100 по модулю)<br>
Выходные данные:
Программа должна вывести одно число - среднее арифметическое квадратов всех целых чисел от a до b (c 2 знаками после запятой)


Информатика (59 баллов) | 50 просмотров
0

Есть же уже ответ на Си, в чём проблема?

Дано ответов: 2
0 голосов
Правильный ответ

Program n1;
var a,b,i: integer;
sum,k: real;
begin
sum:=0;
k:=0;
readln(a,b);
for i:=a to b do
begin
sum:=sum+i*i;
k:=k+1;
end;
writeln(sum/k:6:2);
end.

(150k баллов)
0

в c++

0

вы в вопросе не указали на чем писать, уже поздно)

0 голосов

#include

using namespace std;

int main() {
    int a, b;
    cin >> a >> b;
    int sum = 0;
    for (int i = a; i <= b; i++)<br>        sum += i * i;
    cout.precision(2);
    cout << fixed << (float) sum / (b - a + 1);<br>    return 0;
}

(13.3k баллов)