** вход программе подаются целые числа x и y,необходимо уменьшить ** 100 то число которое...

0 голосов
57 просмотров

На вход программе подаются целые числа x и y,необходимо уменьшить на 100 то число которое является трехзначным.И увеличить в 10 раз то число которое является меньше ста


Информатика (66 баллов) | 57 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
function thg(var t: real): boolean;
begin
thg:=false;
if (t>=100) and(t<1000) then thg:= true;<br>end;
var x,y: real;
begin
readln(x,y);
if thg(x) then x:=x-100;
if thg(y) then y:=y-100;
if x<100 then x:=x*10;<br>if y<100 then y:=y*10;<br>writeln(x,' ',y);
end.

(150k баллов)