Срочно! Запишите соотношение, используемое в приведенной ниже подпрограмме procedure...

0 голосов
281 просмотров

Срочно! Запишите соотношение, используемое в приведенной ниже подпрограмме
procedure f(n:integer);
begin
if n>1 then
begin
f(n div 2);
end;
write ('**');
end;

Определите, сколько звездочек будет выведено в результате вызова f(7) подпрограммы


Информатика (1.9k баллов) | 281 просмотров
Дан 1 ответ
0 голосов

Это рекурсивный вызов процедуры.  При первом вызове F(7)  по условию 
if n>1 then ...  будет вызов этой же процедуры    f(n div 2);  или  f(3),  далее,  т.к. 3>1,  то снова будет вызвана процедура  f(3 div 2)  или f(1),  теперь не выполняется условие  n>1,  следовательно, будет выполнен оператор      write ('**');  -  напечатаются две звездочки, после выхода из процедуры продолжится выполнение процедуры при втором вызове - будут напечатаны еще 2 звездочки, затем продолжится выполнение при первом вызове - еще будут напечатаны 2 звездочки.  В результате вызова f(7) будут напечатаны 6 звездочек  ******.

(9.7k баллов)