Составить программу решения задачи: Найти значение выражения: с=5a-|4a-2b|, где a и b...

0 голосов
41 просмотров

Составить программу решения задачи:
Найти значение выражения: с=5a-|4a-2b|, где a и b произвольные числа


Информатика (133 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
   a, b, c: integer;
begin
   readln(a);
   readln(b);
   c := 5*a-abs(4*a-2*b);
   writeln(c);
end.

Или через случайные числа:
var
   a, b, c: integer;
begin
   randomize;
   a := random(50);
   b := random(50);
   c := 5*a-abs(4*a-2*b);
   writeln(c);
end.

(15.5k баллов)