С++ Написать программу в которой генерируются 10 случайныx чисел в диапазоне от -5 до 30....

0 голосов
60 просмотров

С++
Написать программу в которой генерируются 10 случайныx чисел в диапазоне от -5 до 30. Посчитать среднее арифметическое чисел которые больше 10.
(Использовать цикл for)


Информатика (1.6k баллов) | 60 просмотров
0

А ведь есть среднее арифметическое, и среднее геометрическое..

0

арифметическое,арифметическое

Дано ответов: 2
0 голосов
Правильный ответ

#include
#include
#include
using namespace std;
int main()
{
srand(time(NULL));
int a[10];
int k,sum=0;
cout<<"исходные числа:"<<endl;<br>for(int i=0;i<10;i++)<br>{
a[i]=rand() % 36 - 5;
cout<<a[i]<<' ';<br>if (a[i]>10)
{
k=k+1;
sum=sum+a[i];
}
}
cout<<""<<endl;<br>cout<<"ср. арифм: "<<sum/k<<endl;<br>return 0;
}

(149k баллов)
0 голосов

#include
#include
#include

using namespace std;

int main() {
    int sum = 0;
    int cnt = 0;
    srand(time(0));
    cout << "Numbers: ";<br>    for (int i = 0; i < 10; i++) {
        int a = rand() % 36 - 5;
        cout << a << " ";<br>        if (a > 10) {
            cnt++;
            sum += a;
        }
    }
    cout << "\nAverage value = " << (double) sum / cnt;<br>    return 0;
}

(13.3k баллов)