Составьте программу ** языке Паскаль для следующих задач:1. Найдите сумму всех чисел от a...

0 голосов
38 просмотров

Составьте
программу на языке Паскаль для следующих задач:

1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500).

2. Найдите
среднее арифметическое всех целых чисел от a до b (значение aи b вводится с клавиатуры; a≤b).


3. Дана
последовательность вещественных чисел a1, a2, …, a15, упорядоченная по возрастанию, и,
число n, не равное ни одному из чисел последовательности и такое, что a1≤n≤a15.


a) Определить сумму элементов
последовательности меньших n.


б) Найти два элемента
последовательности (их порядковые номера и значения) в интервале между
которыми, находится число n.


Информатика (42 баллов) | 38 просмотров
Дан 1 ответ
0 голосов

Var i, a, s: integer;
begin
     readln(a);
     for i := a to 500 do
         s := s + i;
     writeln(s);
end.

2) 
var i, a, s, c, b: integer;
begin
     readln(a, b);
     for i := a to b do
     begin
         s := s + i;
         c := c + 1;
     end;
     writeln(s / c:4:2);
end.

3)
const N=10;
var i, b, s: integer;
    a: array [0..N] of integer;
begin
     readln(b);
     for i := 0 to N do a[i] := random(9000);
     for i := 0 to N do
         if (a[i] < b) then s := s + i;
     for i := 0 to N - 2 do
         if (a[i+1] = b) then writeln('(', a[i], '; ', a[i+2], ')');
     writeln(s);
end.

=)

(16.9k баллов)