Написать программу, которая заменяет все отрицательные элементы массива их модулями и...

0 голосов
159 просмотров

Написать программу, которая заменяет все отрицательные элементы массива их модулями и выводит измененный массив на экран


Информатика (12 баллов) | 159 просмотров
Дан 1 ответ
0 голосов

//прога на Pascal`e
const
n = 10;
var
a: array[0..n-1] of shortint;
i: byte;
begin
randomize;

writeln ('Исходный массив: ');
for i:=0 to n-1 do
begin
a[i]:=random (101)-50;
write (a[i], '; ');
end;

writeln ();
writeln ('Измененный массив: ');
for i:=0 to n-1 do
begin
a[i]:=abs (a[i]);
write (a[i], '; ');
end;
end.

(3.8k баллов)