Написать программу определения стоимости разговора по телефону с учётом скидки 20%,...

0 голосов
257 просмотров

Написать программу определения стоимости разговора по телефону с учётом
скидки 20%, предоставляемой по субботам и воскресеньям.
Входные данные:
Sm(стоимость минуты разговора), M (число минут), Day (день недели - 1...7).
Выходные данные: S (стоимость разговора).
Ниже представлен вариант выполнения программы
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб.
1
Длительность разговора (целое количество минут)
6
День недели (1-понедельник, ... 7-воскресенье)
7





Информатика (81 баллов) | 257 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Вычисление стоимости телефонного разговора');
  Writeln('Введите исходные данные');
  var Sm:=ReadReal('Стоимость минуты разговора, руб.');
  var M:=ReadInteger('Длительность разговора (целое количество минут)');
  var Day:=ReadInteger('День недели (1-понедельник, ... 7-воскресенье)');
  var S:=Sm*M*(Day in [1..5]?1.0:0.8);
  Writeln('Стоимость разговора, руб ',s:0:2)
end.

Пример
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб. 1
Длительность разговора (целое количество минут) 6
День недели (1-понедельник, ... 7-воскресенье) 7
Стоимость разговора, руб 4.80
(150k баллов)
0 голосов

Var M, Day : integer; Sm, S : real;
begin
writeln('Вычисление стоимости телефонного разговора');
writeln('Введите исходные данные');
writeln('Стоимость минуты разговора, руб. ');
readln(Sm);
writeln('Длительность разговора (целое количество минут) ');
readln(M);
writeln('День недели (1-понедельник, ... 7-воскресенье) ');
readln(Day);
S:=Sm*M;
if (Day=6)or(Day=7)
 then writeln('Стоимость разговора с учетом скидки = ',S*0.8,' руб')
 else writeln('Стоимость разговора = ',S,' руб');
end.

Пример:
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб. 
1
Длительность разговора (целое количество минут) 
6
День недели (1-понедельник, ... 7-воскресенье) 
7
Стоимость разговора с учетом скидки = 4.8 руб

(194k баллов)