Напишите программу, которая вводит возраст человека (целое число, не превышающее 120)и...

0 голосов
604 просмотров

Напишите программу, которая вводит возраст человека (целое число, не превышающее 120)и выводит этот возраст со словом «год», «года» или «лет». Например, «21 год», «22 года»,«25 лет» на языке Python. Пожалуйста.


Информатика (17 баллов) | 604 просмотров
Дано ответов: 2
0 голосов

A = int(input('возраст: '))
if ((a//10)%10!=1):  
   if ((a%10)==1): print(a,' год')
   else:
       if (((a%10)>1)&((a%10)<5)): print(a,' года')<br>if (((a%10)==0) | ((a%10)>4) | ((a//10)%10==1)): print(a,' лет') 

возраст: 31
31  год

возраст: 103
103  года

возраст: 15
15  лет





(9.7k баллов)
0

"coding: utf-8" для кириллицы точно нужно)

0

Да и печать в Python через запятую лично у меня не очень печатает, скорее возвращает список...

0 голосов

Правильно оформляет любые случаи, даже вне 120.

# -*- coding: utf-8 -*-

def get_word(n):
    no_third = n % 100
    if no_third in range(11, 15):
        return "лет"
    last = no_third % 10
    if last == 1:
        return "год"
    if last in range(2, 5):
        return "года"
    else:
        return "лет"

iage = int(input("Возраст: "))
iword = get_word(iage)
print("{age} {word}".format(age=iage, word=iword))

(7.2k баллов)