Напишите программу, которая печатает все цифры заданного числа по одной в каждой строке...

0 голосов
35 просмотров

Напишите программу, которая печатает все цифры заданного числа по одной в каждой строке начиная с последней цифры. в качестве входных данных допускается ваодить чтсла от 0 до 2 000 000 000


Информатика (26 баллов) | 35 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    n: longint;
begin
    readln(n);
    while n > 0 do
    begin
        writeln(n mod 10);
        n := n div 10;
    end;
end.

(15.5k баллов)