Программа в pascalABC Даны две точки в плоской прямоугольной системе координат. Напишите...

0 голосов
65 просмотров

Программа в pascalABC
Даны две точки в плоской прямоугольной системе координат. Напишите программу, которая позволяет вводить с клавиатуры координаты точек, вычислять расстояние их до начала координат и определять - которая из точек (первая или вторая) находятся ближе к началу координат.


Информатика (21 баллов) | 65 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

type
  Point=(real,real);

procedure GetPoint(var Q:Point);
begin
  var a,b:real;
  Write('Введите координаты точки: '); Read(a,b);
  Q:=(a,b)
end;

function Distance(a:Point):=Sqrt(Sqr(a[0])+Sqr(a[1]));

begin
  var a,b:(real,real);
  GetPoint(a);
  GetPoint(b);
  var d1:=Distance(a);
  var d2:=Distance(b);
  if d1  else
    if d1>d2 then Writeln('Вторая точка ближе')
    else Writeln('Точки равноудалены')
end.

Пример
Введите координаты точки: 13.7 -11.25
Введите координаты точки: 18 12.4
Первая точка ближе
(150k баллов)
0

Так мне нужно, чтобы она считала расстояние между ними

0

Вернее до начал координат

0

вычислять расстояние их до начала координат

0

А, спасибо