Написать программу, которая выводит сумму положительных и кратных трем чисел из вводимой...

0 голосов
33 просмотров

Написать программу, которая выводит сумму положительных и кратных трем чисел из вводимой с клавиатуры последовательности из 47 чисел.


Информатика (83 баллов) | 33 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var a,sum,i: integer;
begin
sum:=0;
for i:=1 to 47 do
begin
readln(a);
if (a>0) and (a mod 3=0) then sum:=sum+a;
end;
writeln(sum);
end.

(150k баллов)