ПОМОГИТЕ ПОЖАЛУЙСТА, ОЧЕНЬ СРОЧНО!! Написать программу с массивом случайных 5 чисел от...

0 голосов
32 просмотров

ПОМОГИТЕ ПОЖАЛУЙСТА, ОЧЕНЬ СРОЧНО!! Написать программу с массивом случайных 5 чисел от -50 до 50, если больше нуля - то сложить их, если меньше нуля - вычесть. (сумма и разность)


Информатика (255 баллов) | 32 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Скорее всего так:
const n=5; 
var a:array[1..n] of integer;
i,s,r:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(101)-50;
 write(a[i]:4);
 end;
writeln;
s:=0; r:=0;
for i:=1 to n do
 if a[i]>0 then s:=s+a[i] else r:=r-a[i];
writeln('s = ',s,' r = ',r);
end.

Пример:
Массив A:
29 32 -48 -42 11
s = 72 r = 90

(194k баллов)
0

Получается, что так. Если число >0, то находим сумму ('+'), а если <0, то находим разность ('-'). Т.е. делаем формально то, что требуется в задаче.

0

!!!

0 голосов

#include
#include
#include

using namespace std;

int main() {
    int a[5], p = 0, n = 0;
    srand ( time(NULL) ); 
    for (int i = 0 ; i < 5 ; i++) {
        a[i]=rand()%100-50;
        cout << a[i] << ' ';<br>        if(a[i] > 0) p+=a[i];
        else n-=a[i];
    }
    cout << endl << p << ' ' << n << endl;  <br>}

(256 баллов)