Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит...

0 голосов
883 просмотров

Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) . Входные данные Входная строка содержит два вещественных числа a и b , разделённых пробелом. Гарантируется, что a < b . Выходные данные Нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.


Информатика (157 баллов) | 883 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program helpglupshkolnikam;
uses crt;
var a, b: real; i: integer;
begin  
randomize;  
readln(a,b);  
for i:= 1 to 5 do    
write(' ',(Random()*(b-a)+a):0:3, ' ');
end.

(102 баллов)
0

Вы пишите для целых, а нужно для вещественных

0

Почему Вы считаете, что программа для целых? Переменные a и b очень даже вещественны.

0

Должно быть выведено 5 вещественных, однако для третьей переменной прописан integer.

0

Программа выводит 5 значений с помощью цикла for, переменная i необходима для работы цикла, это счетчик, и он должен иметь порядковый тип. То есть i никак не связан со значениями, которые выводятся, i - это количество значений, а количество должно быть целым числом. Цикл совершает пять повторов, каждый раз выводит вещественное число, то есть выводит пять вещественных чисел.

0

Благодарю Вас за объяснения, теперь все предельно понятно)