Написать программу, которая находит и выводит ** печать все четырехзначные числа типа...

0 голосов
139 просмотров

Написать программу, которая находит и выводит на печать все четырехзначные числа типа abcd, числа a, b, c, d - различные цифры, для которых выполняется: ab-cd=a+b+c+d на PYTHON!!!


Информатика (29 баллов) | 139 просмотров
Дан 1 ответ
0 голосов
for a in range(1,10):
    for b in range(0,10):
        for c in range(0,10):
            for d in range(0,10):
                if(a != b and b != c and c != d and a != c and b != d & a != d):
                    if(a * b - c * d == a + b + c + d):
                        print(str(a) + str(b) + str(c) + str(d));

(142 баллов)