Помогите написать программу в ПАСКАЛЕ АВС пж Дано четырехзначное число. найти: число,...

0 голосов
40 просмотров

Помогите написать программу в ПАСКАЛЕ АВС пж
Дано четырехзначное число. найти: число, полученное при прочтении его цифр справа налево.


Информатика (133 баллов) | 40 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  n, k: integer;
begin
  readln(n);
  k:=0;
  while n > 0 do
  begin
    k:=k*10 + n mod 10;
    n:=n div 10;
  end;
  writeln(k);
end.

(15.5k баллов)
0

Спасибо большое))