1) Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0)...

0 голосов
55 просмотров

1) Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел. Использовать цикл repeat.

2) Напишите программу, которая выводит на экран таблицу умножения на N, чисел от 0 до 10.
Помогите пожалуйста!(


Информатика (65 баллов) | 55 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)
Program n1;
var a,i,p,sum: integer;
begin
sum:=0;
p:=1;
repeat
readln(a);
if a>0 then sum:=sum+a;
if a<0 then p:=p*a;<br>until (a=0);
writeln('произведение отрицательных: ',p);
writeln('сумма положительных: ',sum);
end.
2)
Program n2;
var n,i:integer;
begin
write('Введите n = ');
readln(n);
writeln('Таблица умножения числа ', n);
for i:=0 to 10 do
writeln(n,'*',i,'=',n*i)
end.

(149k баллов)