Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и...

0 голосов
48 просмотров

Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел. Использовать цикл repeat


Информатика (44 баллов) | 48 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var a,i,p,sum: integer;
begin
sum:=0;
p:=1;
repeat
readln(a);
if a>0 then sum:=sum+a;
if a<0 then p:=p*a;<br>until (a=0);
writeln('произведение отрицательных: ',p);
writeln('сумма положительных: ',sum);
end.

(150k баллов)