Помогите с программированием! Задание: Нужно нарисовать блок схему и написать программу к...

0 голосов
31 просмотров

Помогите с программированием!
Задание: Нужно нарисовать блок схему и написать программу к задаче.
Программу писать нужно на языке Паскаль.( язык Турбо Паскаль).
Вот сама задача :
Вычислить произведения целых чисел от 4 до 7.
Математическая модель : P=4*5*6*7


Информатика (121 баллов) | 31 просмотров
0

это как-то слишком просто, а балов много

0

Нужно подробно все написать, алгоритм схематично, программу, это все время- а за ваше потраченное время- вознаграждение в виде баллов)

0

Поэтому думаю награда соответствен заданию)

0

вот программа

0

var i, p: integer;begin p := 1; for i := 4 to 7 do p := p * i; writeln('P = ', p);end.

0

а что там еще надо сделать не понятно потому в ответ не добавляю

0

Ну схематично, впринципе из программы тоже можно выдернуть) Это тип Начало, ввод и тд

0

с блок схемами сами разбирайтесь. рисовать их не сложно, но долго. Или надо найти инструмент что рисует их автоматически, что тоже время

0

Во,Во, блок схема

0

Поэтому и дал половину своих баллов, я понимаю что это не сложно, но я вообще в программировании не понимаю и для меня это очень даже трудно)

Дан 1 ответ
0 голосов
Правильный ответ

Блок-схема - в прилагаемом файле.
Программу Вам написали правильно:
var
i, p: integer;

begin
p := 1;
for i := 4 to 7 do p := p * i;
writeln('P = ', p);
end.

Результат:
P = 840


image
(194k баллов)
0

Огромное спасибо! Можете помочь еще с одной, сейчас выложу

0