Написать программу которая запросит длинны трёх сторон треугольника. Проверить...

0 голосов
42 просмотров

Написать программу которая запросит длинны трёх сторон треугольника. Проверить возможность его сущ. и в предположенном результате найдёт и выведет на экран площадь один. Ребята!!!! Спасайте кто может!!!!!


Информатика (71 баллов) | 42 просмотров
0

Напишите со знаками препинания и правильными склонениями. Второе предложение абсолютно не понять.

0

Кхе-кхе, вам нужно решение или нет? Объясните, что вы имели в виду вот втором предложении.

0

проверить возможность его существования

0

А дальше?

0

ЧТО ЗНАЧИТ - и в предположенном результате найдёт и выведет на экран площадь один?11!1

0

это так учитель продитовал

0

Ладно. Вот начало, остальные условия не поддаются расшифровки. Покажи хотя бы это, скажи что не поняла условия

0

var a,b,c,d:integer;beginwriteln(d);readln(a,b,c);

0

Скажи, что попыталась

0

хорошо, спасибо те бо е за это!)

Дан 1 ответ
0 голосов
Правильный ответ

Var  
a,b,c{длины сторон}, S{площадь тр.}, p{полупериметр}:double;
begin
writeln('Введите стороны треугольника:');
readln(a,b,c);
     if (a>=b+c) or (b>=a+c) or (c>=a+b) then     
     writeln ('Такого треугольника не существует')     
     else begin   
     p:=(a+b+c)/2;     
     S:=sqrt(p*(p-a)*(p-b)*(p-c)); {вычисляем S тр. по формуле Герона}     
     writeln ('Такой треугольник существует, его S = ', S, 'ед.');     
     end;     
end.

(3.8k баллов)
0

Сайт программу записал в строку... Если она тебе еще нужна, то удали комментарии из программы и разбей ее на столбцы.