Написать программу в Паскаль n-целое число <1000 Испльзуя div и mod определить сколько...

0 голосов
29 просмотров

Написать программу в Паскаль
n-целое число <1000 Испльзуя div и mod определить сколько цифр в этом числе<br> Вычислить сумму цифр числа
Определить чётное оно или нет
Вывести на экран это же число в обратном порядке

Помогите пожалуйста


Информатика (171 баллов) | 29 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Program pos;
var
    n, a, b, c, s, d: integer;
begin
    write('n = ');
    readln(n);
    if n < 1000 then
    begin
        a := n div 100;
        b := n mod 100 div 10;
        c := n mod 10;
        write('В числе ');
        if a = 0 then
            if b = 0 then
            begin
                d := 1;
                writeln('1 цифра');
            end
            else
            begin
                d := 2;
                writeln('2 цифры');
            end
        else
        begin
            d := 3;
            writeln('3 цифры');
        end;
        s := a + b + c;
        writeln('Сумма цифр: ', s);
        if n mod 2 = 0 then
            writeln('Число чётное')
        else
            writeln('Число нечётное');
        if d = 1 then
            writeln(c)
        else
            if d = 2 then
                writeln(c, b)
            else
                writeln(c, b, a);
        end
    else
        writeln('Число > 1000!');
end.

(7.2k баллов)
0

Спасибо большое

0 голосов

Var a,c,n2,n,sum,col:integer;
begin
readln(n);
n2:=n;
a:=0;
sum:=0;
col:=0;
if n<1000 then begin<br>while(n2>0) do begin
  c:=n2 mod 10;
  n2:=n2 div 10;
  a:=(c+a)*10;
  sum:=sum+c;
col:=col+1;
end;
writeln(col);
writeln(sum);
if (n mod 2 =0) then writeln('чётное')
else writeln('нечётное');
writeln(a div 10);
end
else write(n' больше 1000!');
end.

(8.6k баллов)