Помогите написать программу в C++

0 голосов
51 просмотров

Помогите написать программу в C++


image

Информатика (24 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

Нерекурсивная версия:

#include
using namespace std;

int FibGreaterThan(int m) {
if (m < 1) return 1;
int f1 = 1, f2 = 1, f3 = 2;
while (f3 <= m) {<br> f1 = f2;
f2 = f3;
f3 = f1 + f2;
}
return f3;
}

int main() {
int m;
cout << "m = ";<br> cin >> m;
cout << "Результат: "<br> << FibGreaterThan(m) << endl;<br> return 0;
}

(7.2k баллов)