Для каждой задачи составить программу в Pascal, выводящую значение TRUE, если указанное...

0 голосов
225 просмотров

Для каждой задачи составить программу в Pascal, выводящую значение TRUE, если указанное высказывание является истинным, и FALSE - в противном случае


3. Треугольник со сторонами а, в, с является равнобедренным


Информатика (120 баллов) | 225 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a,b:real;
begin
writeln('Введите 1 сторону.');
readln(a);
writeln('Введите 2 сторону.');
readln(b);
if a=b then writeln('TRUE') else writeln('FALSE');
end.

(278 баллов)
0

Var a,b:real;
begin
writeln('Введите 1 сторону.');
readln(a);
writeln('Введите 2 сторону.');
readln(b);
if a=b then writeln('TRUE') else writeln('FALSE')
end.

0

Тысяча извинений!!! Не кажется ли Вам, что надо использовать тип переменной boolean?? ну в смысле по условию задачи...

0

Я не привык :) Ты не с питона пришел случайно ? :)

0

нет. нет. просто я думал надо "ture" или "false" выводить не как текст, а как значение переменной. хотя и как текст в принципе тоже можно... так даже проще...

0 голосов

Var
a,b,c:real;
d: boolean;
begin 
writeln ('Введите строну А: ');
readln(a);
writeln ('Введите строну B: ');
readln(b);
writeln ('Введите строну C: ');
readln(c);
if (a=b)  then d:=true
else d:=false;
writeln (d);
end.

(510 баллов)