Напишите программу ** языке паскаль как найти корни квадратного уравнения ( ax+bx+c=0...

0 голосов
25 просмотров

Напишите программу на языке паскаль
как найти корни квадратного уравнения ( ax+bx+c=0 ),при этом использовав if then else со значениями дискрименанта D=0 D<0 b D>0


Информатика (50 баллов) | 25 просмотров
Дан 1 ответ
0 голосов

Var 
a, b, c, D: real;
  x1, x2: real;
begin
  Write('Введите А:'); Readln(a);
  Write('Введите B:'); Readln(b);
  Write('Введите C:'); Readln(c);
  D := sqr(b) - (4 * a * c);
  if (D > 0) then
 begin
    x1 := (-b + sqrt(D)) / (2 * a);
    x2 := (-b - sqrt(D)) / (2 * a);
    Writeln('x1=', x1);
    Writeln('x2=', x2);  end  else
   if(d = 0) then
 begin
    x1 := b / (2 * a);
    Write('x1=', x1, 'x2=', x1);
  end   else
 writeln('Корней нет');
end.

(7.9k баллов)