Написать программу ** языке Pascal (ABC). Номер 20.2

0 голосов
28 просмотров

Написать программу на языке Pascal (ABC). Номер 20.2


image

Информатика (2.8k баллов) | 28 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var  x, k3, k5: integer;
begin
  repeat
    readln(x);
    if (x mod 3 = 0) and (x > 0) then
       inc(k3);
    if (x mod 5 = 0) and (x > 0) then
       inc(k5);
  until x = 0;
  if k3 > k5 then
     writeln('Кратных 3 больше на ', k3-k5, ' числа')
  else
  if k5 > k3 then
     writeln('Кратных 5 больше на ', k5-k3, ' числа')
  else
     writeln('Одинаково');
end.

(15.5k баллов)