Pascal Составить программу поиска трех значных чисел, сумма цифр которого равна N

0 голосов
31 просмотров

Pascal Составить программу поиска трех значных чисел, сумма цифр которого равна N


Информатика (29 баллов) | 31 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  i, n, s, k: integer;
begin
  readln(n);
  for i := 100 to 999 do
  begin
     s := 0; k := i;
     while  k > 0 do
     begin
        s := s + k mod 10;
        k := k div 10;
     end;
     if s = n then
        writeln(i);
  end;
end.

(15.5k баллов)