Пожалуйста помогите написать программу по информатики для решения задачи: В массиве рост...

0 голосов
54 просмотров

Пожалуйста помогите написать программу по информатики для решения задачи:
В массиве рост юношей задан отрицательным числом, рост девушек положительным, определите отдельно средний рост юношей и девушек.


Информатика (16 баллов) | 54 просмотров
Дан 1 ответ
0 голосов

#include
#include
using namespace std;

int main() {
cout << "Введите массив (0, чтобы закончить):\n";<br> int k,
sb = 0, cb = 0,
sg = 0, cg = 0;
vector v;
while (true) {
cin >> k;
if (k == 0)
break;
else
v.insert(v.end(), k);
}
for (int i = 0; i < v.size(); i++) {
if (v[i] < 0) {
sb += -1 * v[i];
cb++;
}
else {
sg += v[i];
cg++;
}
}
cout << "Средний рост юношей: "<br> << (sb / cb) << '\n'<br> << "Средний рост девушек: "<br> << (sg / cg) << '\n';<br> return 0;
}

(7.2k баллов)
0

а можно это сделать как нибудь примерно так?

0

program xxx;
var M,D,i,ran:integer;
a:array [1..10] of integer;
begin
for i:=1 to 10 do ran:=100-random(200)+1;
for i:=1 to 10 do if a[i]<0 then M:=M+a[i] else D:=D+a[i]; <br>write (M,' ');
write (D,' ')
end.

0

ааа