Составьте программу которая Выводит ** печать элементы массива A[100] значенич которых...

0 голосов
40 просмотров

Составьте программу которая Выводит на печать элементы массива A[100] значенич которых совпадают с индексами


Информатика (16 баллов) | 40 просмотров
Дан 1 ответ
0 голосов

Const
  k = 100;

var
  A: array [1..k] of integer;
  i: integer;

begin
  writeln('Enter x:');
  for i := 1 to k do
  begin
    A[i] := random(k);
    writeln('A[', i, '] = ', A[i]);
  end;
 
  for i := 1 to k do
  begin
    if i = A[i] then
      writeln('A[', i, '] = ', A[i]);
  end;
end.

(16.9k баллов)